BOINC code upgrade

log in

Advanced search

Message boards : News : BOINC code upgrade

Author Message
Greg
Project administrator
Send message
Joined: 26 Jun 08
Posts: 582
Credit: 223,912,432
RAC: 19,453
Message 1634 - Posted: 27 Jan 2016, 23:14:32 UTC
Last modified: 27 Jan 2016, 23:15:09 UTC

I updated the project to the latest version of BOINC. As part of this, I also enabled SSL on the server. Please let me know if you run into any new issues. Thanks for your assistance!

Kevin Arnold
Send message
Joined: 29 Jan 16
Posts: 4
Credit: 5,027,808
RAC: 17,850
Message 1642 - Posted: 4 Feb 2016, 2:29:56 UTC - in response to Message 1634.

On my computer running XP, I get an error trying to log into the message boards.
The message is as follows:
Your connection is not private
You attempted to reach escatter11.fullerton.edu, but the server presented an invalid certificate. You cannot proceed because the website has requested heightened security for this domain.

Greg
Project administrator
Send message
Joined: 26 Jun 08
Posts: 582
Credit: 223,912,432
RAC: 19,453
Message 1643 - Posted: 4 Feb 2016, 6:22:20 UTC - in response to Message 1642.

Logins now use SSL, but it appears that your browser does not recognize the root certificate used on the site. What OS and browser are you using?

Kevin Arnold
Send message
Joined: 29 Jan 16
Posts: 4
Credit: 5,027,808
RAC: 17,850
Message 1644 - Posted: 4 Feb 2016, 13:09:58 UTC - in response to Message 1643.

On Windows XP Opera and Chrome have the problem, while Firefox lets me through.
On FreeBSD it works just fine in Opera.

Greg
Project administrator
Send message
Joined: 26 Jun 08
Posts: 582
Credit: 223,912,432
RAC: 19,453
Message 1645 - Posted: 4 Feb 2016, 18:49:54 UTC - in response to Message 1644.

Perhaps your root certificates need to up updated. Do you have automatic updating turned on?
http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/sag_cmautorootupdt.mspx?mfr=true

Greg
Project administrator
Send message
Joined: 26 Jun 08
Posts: 582
Credit: 223,912,432
RAC: 19,453
Message 1646 - Posted: 5 Feb 2016, 19:04:45 UTC - in response to Message 1645.
Last modified: 5 Feb 2016, 19:09:50 UTC

I looked into this more, and apparently the SSL certificate that the site uses isn't supported in Windows XP. The workaround is to use Firefox, which implements its own SSL rather than relying on WinXP.

https://community.letsencrypt.org/t/help-needed-windows-xp-support/8756

Kevin Arnold
Send message
Joined: 29 Jan 16
Posts: 4
Credit: 5,027,808
RAC: 17,850
Message 1647 - Posted: 7 Feb 2016, 13:24:06 UTC - in response to Message 1646.

Thanks Greg.

Greg
Project administrator
Send message
Joined: 26 Jun 08
Posts: 582
Credit: 223,912,432
RAC: 19,453
Message 1661 - Posted: 27 Mar 2016, 23:02:24 UTC - in response to Message 1647.

Please check now to see if logins work with Windows XP using Chrome or IE 8. Hopefully it is fixed.

Kevin Arnold
Send message
Joined: 29 Jan 16
Posts: 4
Credit: 5,027,808
RAC: 17,850
Message 1662 - Posted: 28 Mar 2016, 2:25:56 UTC - in response to Message 1661.

I tried it with Chrome on Windows XP and logins now work.

Message boards : News : BOINC code upgrade


Home | My Account | Message Boards